Formule Excel ET SI : Maîtrisez les Scénarios Conditionnels en un Clin d’Œil

La fonction « ET » dans Excel est un outil puissant pour créer des formules conditionnelles complexes. Elle vous permet de tester si plusieurs conditions sont toutes vraies simultanément. Par exemple, vous pouvez l’utiliser pour vérifier si un nombre est à la fois supérieur à 10 et inférieur à 20. La compréhension de la fonction « ET » est essentielle pour maximiser l’efficacité de vos feuilles de calcul et affiner l’analyse de vos données.

L’usage de la fonction « ET » peut être étendu en l’associant à la fonction « SI », qui est l’une des fonctions les plus utilisées dans Excel. Cette combinaison vous permet de définir des actions spécifiques en fonction de critères multiples. Par exemple, vous pouvez établir une formule pour attribuer une valeur particulière à une cellule seulement si plusieurs conditions préalables sont remplies. Cela ajoute une dimension supplémentaire à votre gestion de données, rendant vos feuilles de calcul plus interactives et réactives aux variations de vos informations.

Prenons un exemple concret : vous souhaitez attribuer une réduction sur un tarif uniquement si un client est à la fois fidèle (plus de 2 ans de relation) et a dépensé plus de 500 euros au cours de l’année. Avec la fonction « SI » combinée avec « ET », votre formule dans Excel vérifiera simultanément ces deux conditions avant d’appliquer la réduction. Cela garantit une précision et une pertinence dans l’application de vos règles commerciales directement dans votre modèle Excel.

Principes de Base

La fonction ET est un outil essentiel dans Excel pour tester plusieurs conditions à la fois. C’est une fonction logique qui renvoie VRAI uniquement si toutes les conditions spécifiées sont vraies.

Syntaxe de la Fonction ET

La syntaxe de la fonction ET est simple :

=ET(condition1; condition2; ...)

Condition1, Condition2, … : Ce sont les conditions que vous souhaitez tester. Vous pouvez tester jusqu’à 255 conditions avec la fonction ET.

Utilisation de la Fonction ET

Pour utiliser la fonction ET dans vos feuilles de calcul Excel, suivez ces étapes :

  1. Sélectionnez la cellule où vous souhaitez afficher le résultat.
  2. Tapez =ET(, suivi des conditions que vous voulez vérifier.
  3. Séparez chaque condition par un point-virgule ;.
  4. Fermez les parenthèses ) et appuyez sur Entrée.

Pour illustrer, supposez que vous voulez vérifier si la valeur de la cellule A1 est supérieure à 10 et si celle de la cellule B1 est inférieure à 20. Votre formule ressemblerait à ceci :

=ET(A1>10; B1<20)

Si A1 contient 15 et B1 contient 15, la formule renverra VRAI.

Formules Combinées

Les formules combinées d’Excel vous permettent d’analyser des données complexes en intégrant plusieurs conditions logiques dans une seule formule. Voyons comment elles fonctionnent en pratique.

ET avec SI

Utilisez la combinaison ET avec SI pour tester plusieurs conditions à la fois. Par exemple, si vous souhaitez vérifier que deux conditions sont remplies avant d’effectuer un calcul, la formule sera structurée comme suit:

=SI(ET(condition1;condition2);valeur_si_vrai;valeur_si_faux)

Exemple: Pour vérifier si A2 est supérieur à 10 et que B2 est égal à « Oui », la formule sera:

=SI(ET(A2>10, B2="Oui");"Condition remplie";"Condition non remplie")

ET avec OU

La combinaison de ET avec OU vous permet d’exécuter des scénarios où plusieurs groupes de conditions peuvent être valides. Voici la syntaxe de base:

=SI(OU(ET(condition1_1;condition1_2);ET(condition2_1;condition2_2));valeur_si_vrai;valeur_si_faux)

Exemple: Pour une facture, si le produit A (A2) est en stock et que la demande est urgente (B2), ou si le produit B (C2) est en stock et en promotion (D2), alors passer la commande:

=SI(OU(ET(A2="En Stock";B2="Urgent");ET(C2="En Stock";D2="Promo"));"Passer commande";"Ne pas commander")

ET avec des Fonctions Statistiques

Les fonctions statistiques comme SOMME.SI.ENS ou MOYENNE.SI.ENS améliorent les analyses en utilisant ET pour mettre en place des critères multiples. Par exemple, la formule SOMME.SI.ENS se présente comme ceci:

=SOMME.SI.ENS(plage_somme;critère_plage1;critère1;[critère_plage2, critère2];...)

Exemple: Pour calculer la somme des ventes de la région « Est » (B2) pour le produit « X » (C2), voici comment procéder:

=SOMME.SI.ENS(A2:A100;B2:B100;"Est";C2:C100, "X")

Cas Pratiques

Dans cette section, vous découvrirez des applications concrètes de la fonction ET dans Excel, qui vous aideront à optimiser l’analyse de vos données, à gérer les erreurs potentielles et à simuler différents scénarios.

Analyse de Données

Lorsque vous analysez des données, ET peut être utilisé pour tester simultanément plusieurs conditions. Par exemple, si vous avez une liste d’employés avec des heures travaillées et des taux horaires, vous pouvez déterminer qui a fait plus de 40 heures par semaine et bénéficie d’un taux horaire supérieur à 50 €.

Employé Heures travaillées Taux horaire (€) Éligible pour Bonus
Jean 45 55 =ET(B2>40, C2>50)
Marie 38 60 =ET(B3>40, C3>50)
Pierre 42 49 =ET(B4>40, C4>50)

Gestion des Erreurs

Pour prévenir les erreurs lors de l’utilisation de ET, vous pouvez combiner SI et ESTERREUR. Cela permet d’afficher un message personnalisé ou d’exécuter une action spécifique si les conditions échouent en raison d’une erreur.

=SI(ESTERREUR(ET(A2>0, B2<0));"Vérification nécessaire";ET(A2>0, B2<0))

Cette formule vérifie si les valeurs de A2 et B2 respectent les conditions; si une erreur est rencontrée, elle affiche « Vérification nécessaire ».

Scénarios Conditionnels

Utiliser ET avec SI permet de créer des scénarios conditionnels complexes. Par exemple, pour attribuer des bonus basés sur les performances des ventes et la satisfaction client, vous utiliseriez la fonction ET pour évaluer si les deux critères sont remplis.

=SI(ET(C2>=100000, D2>=90%);"Bonus de 10%";"Pas de bonus")

Cette formule évalue si les ventes sont supérieures ou égales à 100 000 € et si le niveau de satisfaction client est d’au moins 90%, attribuant un bonus de 10% seulement si les deux conditions sont vraies.

Fonctions Avancées

En exploitant les fonctions avancées d’Excel, vous pouvez effectuer des analyses complexes et gérer des données à grande échelle avec précision.

Imbrication des Fonctions ET et SI

Vous pouvez renforcer la puissance des formules en combinant les fonctions ET et SI pour gérer des conditions multiples. Par exemple:

=SI(ET(A1>0, B1<10);"Valide";"Invalide")

Cette formule vérifie simultanément si la cellule A1 contient une valeur supérieure à 0 et si la cellule B1 contient une valeur inférieure à 10. Si les deux conditions sont vraies, le résultat affiché sera « Valide ». Sinon, le résultat sera « Invalide ».

Utiliser ET avec des Tableaux

L’utilisation de la fonction ET avec des tableaux peut vous permettre de vérifier rapidement des conditions à travers une gamme de données. Considérez le tableau suivant:

A B
4 8
5 2
-1 10

Pour vérifier si toutes les valeurs dans la colonne A sont positives et celles de la colonne B sont inférieures à 10, utilisez:

=ET(A1:A3>0;B1:B3<10)

Cette formule retournera FAUX car bien que toutes les valeurs de la colonne A soient supérieures à 0, la cellule B3 contient une valeur non conforme à la seconde condition.

Optimisation et Bonnes Pratiques

Dans cette section, vous apprendrez comment améliorer la performance de vos formules et assurer la clarté de votre code pour une maintenance simplifiée.

Performance des Formules

Pour optimiser vos formules Excel, utilisez des références de cellules plutôt que des plages entières. Par exemple, préférez SOMME(A1:A10) à SOMME(A:A) qui calculerait sur toutes les lignes de la colonne. Évitez également les fonctions volatiles telles que INDIRECT et AUJOURDHUI qui forcent Excel à recalculer la cellule à chaque action dans le classeur.

Gestion des calculs itératifs : Si vous devez utiliser des calculs itératifs, tel que SOMMEPROD, réglez le nombre d’itérations dans les options Excel pour limiter le temps de calcul.

Types de données : Utilisez des types de données appropriés. Par exemple, stockez les dates en tant que telles plutôt que des chaînes de texte pour optimiser les calculs liés au temps.

Formules matricielles : Évitez les anciennes formules matricielles si possible et préférez les fonctions dynamiques qui gèrent mieux les grands ensembles de données.

Action Avant Après
Référencement des cellules =SOMME(Feuille2!A:A) =SOMME(Feuille2!A1:A10)
Utilisation des fonctions =SI(ESTERREUR(RechercheV(…));"Non trouvé";RechercheV(…)) =SIERREUR(RechercheV(…);"Non trouvé")
Fonctions volatiles =AUJOURDHUI() =DATE(ANNEE(MAINTENANT());MOIS(MAINTENANT()), JOUR(MAINTENANT()))

Clarté et Maintenance du Code

Assurez-vous que vos formules sont faciles à lire et à comprendre pour toute personne qui pourrait reprendre votre travail. Commentez vos formules quand cela est nécessaire pour expliquer la logique ou la raison d’être d’un calcul particulier. Nommez vos plages pour que vos formules soient plus intuitives : préférez =SOMME(Ventes) à =SOMME(A1:A10).

Simplification des formules : Décomposez les formules complexes en plusieurs étapes pour faciliter la compréhension et le débogage. Vous pouvez utiliser des cellules intermédiaires pour des calculs intermédiaires.

Constantes nommées : Utilisez des constantes nommées pour les valeurs qui ne changent pas, comme les taux d’intérêt ou les coefficients.

Tables structurées : Utilisez les tables Excel pour une meilleure lisibilité. L’utilisation de noms de colonne dans les formules plutôt que de références de cellule rend le travail avec les données beaucoup plus clair.

Révisions et mise à jour : Révisez régulièrement vos feuilles de calcul pour mettre à jour les formules obsolètes et supprimer les données inutiles qui pourraient ralentir le performance de votre classeur.

Dépannage et Erreurs Courantes

Lors de l’utilisation de la fonction ET dans Excel, vous pouvez rencontrer des problèmes de logique ou d’erreurs de référence. Comprendre ces problèmes communs et savoir comment les résoudre est essentiel pour maintenir l’intégrité de vos formules.

Résoudre les Problèmes Logiques

Pour résoudre les problèmes liés à la logique de la fonction ET, vérifiez d’abord que chaque condition testée renvoie un résultat VRAI ou FAUX. La fonction ET ne renvoie VRAI que si toutes les conditions spécifiées sont vraies. Voici quelques points à vérifier :

  • Conditions Contradictoires : Assurez-vous qu’aucune des conditions testées ne se contredit.
  • Données d’Entrée : Confirmez que les données utilisées dans les conditions sont correctes et n’incluent pas d’erreurs de saisie.
  • Utilisation des Guillemets : Si vous testez des chaînes de texte, les valeurs doivent être placées entre guillemets (par exemple, ET(A1="oui";A2="non")).

Éviter les Erreurs de Référence

Les erreurs de référence surviennent lorsque la formule contient des cellules, des plages ou des noms qui ne sont pas reconnus par Excel. Pour éviter ces erreurs, suivez ces conseils :

  • Vérification des Cellules : Assurez-vous que les références de cellules dans votre formule pointent vers les bonnes cellules et que ces cellules contiennent des données valides.
  • Noms de Plages : Si vous utilisez des noms pour vos plages, vérifiez que les noms sont exacts et bien définis dans le gestionnaire de noms.
  • Références Absolues et Relatives : Comprenez la différence entre les références relatives (A1) et absolues ($A$1) et employez-les correctement pour s’assurer que la formule se met à jour de manière appropriée lorsqu’elle est copiée vers un autre emplacement.

Formations :

icone etoile lead magnet

Les raccourcis indispensables d'Excel

Tu veux augmenter ta vitesse de travail et faire exploser ta productivité ?
Utiliser Excel sans toucher à ta souris toutes les 10 secondes ?
Découvre les meilleurs raccourcis à connaître sur Excel.

Cet article t'a plu ? Partage-le !
Email
LinkedIn
Facebook
A propos de l'auteur

Je suis Thomas Coget, expert Excel.
Depuis 2021, j’aide les entreprises et les salariés à développer leur expertise sur Excel grâce à une méthode efficace, ludique et accessible. 

Tu aimeras peut-être aussi :
Icone graphique Exceleur
Icone graphique Exceleur

Newsletter

Recevoir La #REFérence toutes les 2 semaines