Excel formule SIERREUR : Guide essentiel pour la gestion des erreurs

La gestion des erreurs est une tâche cruciale lors de l’utilisation des formules dans Excel. L’une des meilleures façons de gérer ces erreurs est d’utiliser la fonction Excel « SIERREUR ». Cette fonction vous permet de vérifier si la valeur entrée dans une formule est une erreur et de renvoyer une valeur alternative si c’est le cas, rendant ainsi vos tableaux plus clairs et compréhensibles.

Le fonctionnement de la formule SIERREUR est simple : elle prend deux arguments, la valeur à tester et la valeur à retourner en cas d’erreur. Par exemple, si vous souhaitez vérifier si une formule génère une erreur et afficher « Non disponible » à la place de l’erreur, vous pouvez utiliser SIERREUR pour atteindre cet objectif. En maîtrisant l’utilisation de SIERREUR, vous serez en mesure de gérer plus efficacement les erreurs et d’améliorer la présentation de vos données dans Excel.

Comprendre la fonction SIERREUR

Définition et Syntaxe de SIERREUR

La fonction SIERREUR est un outil précieux pour gérer les erreurs dans Excel. Elle vérifie si une valeur ou une formule retourne une erreur et, dans ce cas, remplace l’erreur par une valeur définie spécifiquement.

Sa syntaxe est la suivante :

SIERREUR(valeur, valeur_si_erreur)
  • valeur : il s’agit de l’argument ou de la formule dont vous souhaitez vérifier l’exactitude.
  • valeur_si_erreur : la valeur ou le message à afficher en cas d’erreur.

Erreurs courantes dans Excel et leur signification

Voici une liste des erreurs courantes dans Excel et leurs significations :

  • #N/A : La fonction RECHERCHEV recherche des informations à partir d’une liste, mais n’arrive pas à trouver la valeur demandée.
  • #REF! : Une référence n’est pas valide, par exemple lorsqu’une cellule référencée est supprimée.
  • #DIV/0! : Une division par zéro est effectuée, ce qui n’est pas autorisé dans les calculs mathématiques.
  • #VALEUR! : Une erreur se produit lorsque Excel attend une valeur numérique, mais trouve une chaîne de texte ou une erreur dans la cellule référencée.
  • #NOMBRE! : Une erreur survient lorsque l’opération mathématique ou la fonction utilisée n’accepte pas les données fournies en entrée.
  • #NOM? : Excel ne reconnaît pas un nom de fonction ou de plage de cellules.
  • #NUL! : Deux plages de cellules n’ont pas d’intersection ou se chevauchent.

Pour utiliser la fonction SIERREUR afin de gérer ces erreurs, voici un exemple :

=SIERREUR(RECHERCHEV(B2,$G$1:$H$100,2,FALSE),"Non trouvé")

Dans cet exemple, si la fonction RECHERCHEV retourne une erreur #N/A, Excel affichera « Non trouvé » à la place de l’erreur. Ainsi, votre feuille de calcul fonctionnera sans problèmes, donnant une présentation visuelle plus professionnelle et rendant l’analyse des données plus facile.

Utilisation de SIERREUR dans les formules

La fonction SIERREUR d’Excel est utile pour éviter l’apparition d’erreurs dans les formules et pour obtenir des résultats plus clairs. Correctement utilisée, SIERREUR peut aider à améliorer la lisibilité de vos chiffriers. Cette section vous apprendra comment utiliser SIERREUR et vous présentera divers exemples.

Exemples de base de SIERREUR

Exemple 1: Imaginons que vous voulez diviser un nombre par le contenu d’une cellule A1, mais vous ne savez pas si la cellule contient une valeur valide pour la division. La syntaxe de base de la fonction SIERREUR est la suivante :

=SIERREUR(valeur, valeur_si_erreur)

Dans ce cas, vous pouvez utiliser SIERREUR pour éviter d’afficher une erreur si A1 est égal à zéro ou ne contient aucune valeur. Par exemple :

=SIERREUR(100 / A1, "Erreur")

Si A1 contient une valeur valide, le résultat de la division sera affiché. Si A1 est égal à zéro ou ne contient aucune valeur, Excel affichera « Erreur » à la place.

Exemple 2: Imaginez maintenant que vous avez une liste de prix et que vous voulez calculer la somme totale. Cependant, certaines cellules peuvent être vides ou contenir des erreurs de saisie. Vous pouvez utiliser SIERREUR pour ignorer ces cellules lors de l’addition. Par exemple :

=SOMME(SIERREUR(A1, 0), SIERREUR(A2, 0), SIERREUR(A3, 0))

Dans cet exemple, si A1, A2, ou A3 contiennent une erreur, SIERREUR renvoie « 0 » pour ces cellules, et elles ne seront pas considérées dans la somme.

SIERREUR combinée avec d’autres fonctions

Exemple 1: Vous pouvez combiner SIERREUR avec d’autres fonctions Excel, comme RECHERCHEV, pour obtenir des résultats plus lisibles. Par exemple, si vous cherchez un produit dans une liste et que vous voulez afficher son prix, vous pouvez utiliser la fonction RECHERCHEV ainsi :

=SIERREUR(RECHERCHEV(C1, A1:B10, 2, FAUX), "Produit non trouvé")

Dans cet exemple, si le produit est trouvé dans la plage A1:B10, Excel affiche son prix. Si le produit n’est pas trouvé, Excel affiche « Produit non trouvé » à la place d’une erreur.

Exemple 2: Vous pouvez également utiliser SIERREUR avec d’autres fonctions pour gérer les erreurs potentielles, comme dans l’exemple suivant avec la fonction SOMME :

=SIERREUR(SOMME(A1:B1) / SOMME(A2:B2), "Erreur de division")

Ici, si la somme des cellules A2 et B2 est nulle ou invalide pour la division, Excel affiche « Erreur de division » au lieu d’afficher une erreur.

En résumé, la fonction SIERREUR est un outil précieux pour améliorer la lisibilité et la qualité de vos chiffriers Excel. Elle vous permet de gérer efficacement les erreurs et de combiner SIERREUR avec d’autres fonctions pour créer des formules solides et fiables.

Gestion des Erreurs avec SIERREUR

La fonction SIERREUR est un outil essentiel pour gérer les erreurs dans les formules Excel. Cette fonction vous permet de personnaliser la manière dont les erreurs sont affichées, prévenir les erreurs de calcul et afficher des messages personnalisés pour les erreurs. Voici comment vous pouvez tirer pleinement parti de cette fonction.

Prévention des erreurs de calcul

Pour éviter les erreurs de calcul causées par une division par zéro, vous pouvez utiliser la fonction SIERREUR dans vos formules. Par exemple, si vous voulez diviser un nombre par une cellule B2 et éviter les erreurs lorsque B2 est égal à zéro, vous pouvez utiliser la formule suivante :

=SIERREUR(A2 / B2, "Erreur de calcul")

Dans cette formule, la valeur_si_erreur est « Erreur de calcul », qui sera affichée si une erreur se produit. Sinon, le résultat de la division sera affiché.

Liste des erreurs courantes:

  • #N/A
  • #VALEUR!
  • #REF!
  • #DIV/0!
  • #NOMBRE!
  • #NOM?
  • #NUL!

Affichage de messages personnalisés pour les erreurs

La fonction SIERREUR vous offre également la possibilité d’afficher des messages personnalisés pour mieux expliquer la nature de l’erreur. Par exemple, si vous souhaitez afficher un message spécifique en cas d’erreur de division par zéro, vous pouvez utiliser la formule suivante :

=SIERREUR(A2 / B2, "Vérifiez la valeur de la cellule B2")

Si une erreur est détectée, le message « Vérifiez la valeur de la cellule B2 » apparaîtra dans la cellule au lieu de l’erreur standard #DIV/0!. Cette personnalisation permet à l’utilisateur de comprendre et de résoudre plus facilement le problème.

En somme, maîtriser l’utilisation de la fonction SIERREUR peut vous aider à gérer efficacement les erreurs dans vos feuilles de calcul Excel. Cette fonction vous permet de prévenir les erreurs de calcul et d’afficher des messages d’erreur personnalisés pour faciliter la compréhension et la résolution des problèmes. Apprenez à utiliser SIERREUR pour améliorer la qualité et la clarté de vos feuilles de calcul et rendre votre travail sous Excel plus professionnel et convivial.

Formules Complexe avec la fonction SIERREUR

La fonction SIERREUR est particulièrement utile lors de la création de formules complexes dans Excel, car elle permet de gérer les erreurs qui peuvent survenir lors de la manipulation de données dans des tableaux ou des formules matricielles.

Instructions et exemples de formules de tableau

Les formules de tableau permettent d’effectuer des calculs sur une plage de cellules plutôt que sur des cellules individuelles. Voici un exemple de l’utilisation de la fonction SIERREUR dans une formule de tableau :

  1. Sélectionnez un ensemble de cellules vide où vous souhaitez afficher les résultats de la formule.
  2. Saisissez la formule suivante sans appuyer sur Entrée : =SIERREUR(VOTRE_FORMULE,"Erreur")
  3. Remplacez VOTRE_FORMULE par la formule de tableau que vous souhaitez utiliser.
  4. Maintenant, appuyez sur Ctrl+Shift+Entrée pour entrer la formule en tant que formule de tableau.

Supposons que vous avez un tableau avec des chiffres dans la plage A1 et que vous souhaitez diviser les valeurs de la colonne A par celles de la colonne B. Vous pouvez utiliser la formule ci-dessous en suivant les étapes mentionnées précédemment :

=SIERREUR(A1:A5/B1:B5, "Division par zéro")

Cette formule renverra le résultat de la division ou affichera « Division par zéro » si la valeur de la colonne B est égale à zéro.

Formules matricielles avec accolades

Les formules matricielles permettent d’effectuer des opérations sur des tableaux de données en utilisant des accolades ({}) pour délimiter le début et la fin de la matrice. La fonction SIERREUR peut également être utilisée dans ce contexte pour gérer les erreurs.

Voici un exemple de formule matricielle utilisant la fonction SIERREUR. Supposons que vous ayez un tableau de données sur deux colonnes (colonne A et colonne B), et que vous souhaitiez calculer la somme des produits de chaque paire de valeurs :

  1. Sélectionnez une cellule vide où vous souhaitez afficher le résultat de la formule.
  2. Saisissez la formule suivante sans appuyer sur Entrée : =SIERREUR(SOMME(A1:A5*B1:B5),"Erreur")
  3. Appuyez sur Ctrl+Shift+Entrée pour entrer la formule en tant que formule matricielle.

La formule SIERREUR permet ici d’afficher le résultat de la somme des produits ou « Erreur » si une erreur survient lors du calcul. L’utilisation judicieuse de la fonction SIERREUR dans vos formules complexes d’Excel, pour les tableaux ou les formules matricielles, permet non seulement de présenter des données plus lisibles, mais aussi de faciliter la détection et la gestion des erreurs.

Optimiser l’utilisation de SIERREUR

SIERREUR et les résultats de recherche

Lorsque vous travaillez avec des données dans Excel, il est fréquent de rencontrer des erreurs. La fonction SIERREUR est un outil précieux pour gérer ces erreurs et améliorer la présentation de vos résultats. En combinant SIERREUR avec d’autres fonctions telles que RECHERCHEV et GAUCHE, vous pouvez optimiser l’affichage de vos données.

Par exemple, supposons que vous utilisiez la fonction RECHERCHEV pour rechercher des informations dans un tableau. Si la valeur recherchée n’est pas trouvée, RECHERCHEV renverra une erreur #N/A. Pour éviter que cette erreur n’apparaisse dans votre feuille de calcul, vous pouvez combiner RECHERCHEV avec SIERREUR.

=SIERREUR(RECHERCHEV(A2,Table1,2,FAUX), "Non trouvé")

Dans cet exemple, si RECHERCHEV retourne une erreur, la fonction SIERREUR affiche « Non trouvé » à la place.

Combinaison de SIERREUR avec SOMME et autres fonctions statistiques

SIERREUR peut également être utilisé en combinaison avec des fonctions statistiques telles que SOMME, MOYENNE, et Médiane. En utilisant SIERREUR avec ces fonctions, vous pouvez éviter que des erreurs n’affectent vos résultats statistiques. Par exemple, si vous avez une série de données contenant des erreurs, vous pouvez utiliser la formule suivante :

=SOMME(SIERREUR(B2:B10, 0))

Dans cet exemple, la fonction SIERREUR vérifie chaque valeur de la plage B2. Si une erreur est détectée, SIERREUR la remplacera par 0. Ensuite, la fonction SOMME additionne les valeurs obtenues sans tenir compte des erreurs.

En résumé, la fonction SIERREUR est un outil indispensable pour gérer les erreurs dans Excel et maintenir la clarté de vos feuilles de calcul. En combinant SIERREUR avec d’autres fonctions telles que RECHERCHEV et les fonctions statistiques, vous pouvez optimiser l’utilisation de cette fonction et présenter vos données de manière plus efficace.

Travailler avec des Tableaux et Plages dans Excel

Application de SIERREUR dans les tableaux dynamiques

Lorsque vous travaillez avec des tableaux dynamiques dans Excel, il est possible que certaines erreurs apparaissent. Pour gérer ces erreurs, vous pouvez utiliser la fonction SIERREUR. Cette fonction permet de renvoyer une valeur spécifique si une erreur est détectée dans une formule.

Par exemple, imaginez que vous ayez un tableau dynamique avec les colonnes suivantes : Prix, Quantité et Total. Vous voulez calculer le total en multipliant le prix par la quantité. Toutefois, certains prix ou quantités peuvent être manquants et générer des erreurs. Vous pouvez utiliser SIERREUR pour gérer ces erreurs :

=SIERREUR(Prix * Quantité, 0)

Dans cet exemple, si une erreur est détectée, la fonction renvoie 0 comme valeur du total.

Gestion des plages de cellules avec SIERREUR

L’utilisation de la fonction SIERREUR est également utile pour gérer des plages de cellules et des tableaux dans Excel. Par exemple, si vous souhaitez trouver la moyenne d’une plage de cellules mais que certaines valeurs génèrent des erreurs, SIERREUR peut vous aider à gérer ces erreurs.

Supposons que vous ayez une plage de valeurs numériques avec quelques erreurs. Vous pouvez utiliser une formule matricielle pour appliquer SIERREUR à chaque cellule avant de calculer la moyenne :

  1. Sélectionnez une cellule où vous souhaitez afficher la moyenne.
  2. Entrez la formule suivante :
=MOYENNE(SIERREUR(<Plage_de_cellules>, 0))

Remplacez <Plage_de_cellules> par la plage que vous souhaitez analyser.

  1. Appuyez sur Ctrl+Maj+Entrée au lieu d’Entrée pour valider la formule matricielle. Excel ajoutera des accolades {} autour de la formule pour indiquer qu’il s’agit d’une formule matricielle.

À l’aide de cette formule, SIERREUR remplacera toutes les erreurs par 0, ce qui permettra de calculer la moyenne sans tenir compte des erreurs.

En résumé, la fonction SIERREUR dans Excel est un outil puissant pour gérer et contourner les erreurs dans les tableaux et les plages de cellules. Son utilisation vous permettra de créer des formules plus robustes et de faciliter l’analyse de vos données.

Version et Compatibilité d’Excel avec SIERREUR

SIERREUR dans Excel 2016, 2013, 2010, et 2007

La fonction SIERREUR est disponible et compatible avec différentes versions d’Excel, y compris Excel 2016, Excel 2013, Excel 2010 et Excel 2007. Cela signifie que vous pouvez compter sur cette fonction pour masquer les messages d’erreur de vos formules dans ces versions du logiciel. Voici un exemple de mise en œuvre de la fonction SIERREUR :

=SIERREUR(RECHERCHEV(E2;A2:C11;3;FAUX);"-")

Dans cet exemple, la fonction SIERREUR est utilisée avec la fonction RECHERCHEV pour afficher un tiret (-) en cas d’erreur, au lieu d’une valeur d’erreur classique.

SIERREUR dans Microsoft 365 et Excel Web App

La fonction SIERREUR est également disponible dans Microsoft 365 et Excel Web App. Vous pouvez donc l’utiliser pour gérer les erreurs dans vos fichiers Excel en ligne.

Voici un résumé des compatibilités de la fonction SIERREUR avec les différentes versions d’Excel :

Version d’Excel Disponibilité de SIERREUR
Excel 2021 Oui
Excel 2019 Oui
Excel 2016 Oui
Excel 2013 Oui
Excel 2010 Oui
Excel 2007 Oui
Microsoft 365 Oui
Excel Web App Oui

En résumé, la fonction SIERREUR est disponible dans la plupart des versions d’Excel, y compris les versions les plus anciennes et récentes, ainsi que les versions en ligne. Vous pouvez utiliser cette fonction pour gérer et masquer les erreurs dans vos formules Excel en toute confiance.

Fonctions Avancées et Personnalisation

Création de listes déroulantes et validation des données avec SIERREUR

Dans Excel, la fonction SIERREUR peut être utilisée pour créer des listes déroulantes et valider les données. Vous pouvez créer une liste déroulante en ajoutant des conditions à votre formule SIERREUR. Par exemple, supposez que vous ayez une colonne avec des valeurs et que vous souhaitiez afficher un message personnalisé en cas d’erreur.

Dans ce cas, vous pouvez utiliser SIERREUR de la manière suivante :

=SIERREUR(votre_formule, valeur_si_erreur)

La fonction vérifie d’abord si votre_formule génère une erreur. Si c’est le cas, elle renvoie la valeur_si_erreur spécifiée. Sinon, elle renvoie simplement le résultat de la formule. Cette méthode est utile pour personnaliser les messages d’erreur et améliorer la lisibilité de votre feuille de calcul.

Support et Ressources Complémentaires

Formation et Cours en Ligne

Si vous êtes intéressé par des cours de formation plus approfondis, notre formation Le Décollage pourrais bien vous intéresser.

N’hésitez pas à vous inscrire à la liste d’attente pour ne pas manquer la prochaine ouverture de la formation.

En attendant, formez vous gratuitement grâce à notre guide complet des TCD d’Excel. 

Et augmentez votre productivité grâce aux raccourcis indispensables d’Excel.

icone etoile lead magnet

Les 10 formules indispensables sur Excel

Tu veux utiliser Excel comme un pro, augmenter ton efficacité et arrêter de t’arracher les cheveux devant ton tableur ?

Découvre les 10 formules à absolument connaître sur Excel.
Avec des exemples concrets et des explications ULTRA simples et limpides !

Cet article t'a plu ? Partage-le !
Email
LinkedIn
Facebook
A propos de l'auteur

Je suis Thomas Coget, expert Excel.
Depuis 2021, j’aide les entreprises et les salariés à développer leur expertise sur Excel grâce à une méthode efficace, ludique et accessible. 

Tu aimeras peut-être aussi :
Icone graphique Exceleur
Icone graphique Exceleur

Newsletter

Recevoir La #REFérence toutes les 2 semaines
icone etoile lead magnet

Les 10 formules indispensables sur Excel

Tu veux utiliser Excel comme un pro, augmenter ton efficacité et arrêter de t’arracher les cheveux devant ton tableur ?

Découvre les 10 formules à absolument connaître sur Excel.
Avec des exemples concrets et des explications ULTRA simples et limpides !